Люто, бешено

Напоминалка, чтобы не забыть как плясать, чтобы eToken работал в линуксе.

1 – Сходить на http://www.aladdin.ru/support/download/detail.php, убедиться, что именно моего Линукса нет в списке поддерживаемых, скачать eToken_PKI_Client_4_55_Linux.rar, потому, что 5й еще сильнее гадит в системе.

2 – Установить pcscd, opensc, openct.

3 – Распаковать драйвер, устанновить пакет.

4 – Скачать https://launchpad.net/ubuntu/hardy/i386/pcscd/1.4.99-1ubuntu1, вынуть из него бинарник pcscd и положить его в /usr/sbin. Потому, что 1.4.102 тихо падает.

5 – Запилить /etc/ld.conf.d/etoken. Потому, что он прописывает свои QT, NSS3 и много чего, что мешает работать нормальным программам. Все равно реально кроме файрфокса авторизация по токену мне нигде не нужна.

6 – Объяснить файрфоксу как работать с етокеном, указав /usr/lib/libeTKcs11.so в качестве устройства безопасности.

За каким хреном они тянут за собой половину системных библиотек? Нет, я понимаю, за каким, но неужели нельзя нормально сделать, не через жопу, так, что обновления безопасности порождают unresolved symbols! Ну ясно же, что если даже оно протестировано на свежем редхете, то нормально оно все равно работать не станет.